import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>The post <a\\s+.*?href=\".*?\"\\s+.*?>.*?<\\/a> appeared first on <a\\s+.*?href=\".*?\"\\s+.*?>.*?<\\/a>.<\\/p>\n";
final String string = "<p>The post <a rel=\"nofollow\" href=\"link\" >title</a> appeared first on <a rel=\"nofollow\" href=\"Website.com\" >Website</a>.</p>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}