re = /<p>The post <a\s+.*?href=".*?"\s+.*?>.*?<\/a> appeared first on <a\s+.*?href=".*?"\s+.*?>.*?<\/a>.<\/p>
/m
str = '<p>The post <a rel="nofollow" href="link" >title</a> appeared first on <a rel="nofollow" href="Website.com" >Website</a>.</p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end