$re = '/(?s)(?<!\\\\)((?:\\\\{2})*)\"([^\"\\\\]*(?:\\\\.[^\"\\\\]*)*)\"/';
$str = '["\\n","\\t","\'","\\"","\\\\","\\\\\\""]
// \\"
var s = "d\\"d\\\\\\"f";';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;