re = /(?s)(?<!\\)((?:\\{2})*)\"([^\"\\]*(?:\\.[^\"\\]*)*)\"/
str = '["\\n","\\t","\'","\\"","\\\\","\\\\\\""]
// \\"
var s = "d\\"d\\\\\\"f";'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result