#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<(a|img)(?:\s[^>]*)*>)((?:(?!<\1).)*)"
Local $sString = "" & @CRLF & _
"<img>content</img> <img src="some-pic-url">content</img>" & @CRLF & _
"<a> content </a> <a href="url">content</a>" & @CRLF & _
"" & @CRLF & _
"<a href="url">content</img>" & @CRLF & _
"<img src="some-pic-url">content</a>" & @CRLF & _
"<a href="url">content" & @CRLF & _
"<img src="some-pic-url">content"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")