use strict;
my $str = '
<img>content</img> <img src="some-pic-url">content</img>
<a> content </a> <a href="url">content</a>
<a href="url">content</img>
<img src="some-pic-url">content</a>
<a href="url">content
<img src="some-pic-url">content';
my $regex = qr/(?:<(a|img)(?:\s[^>]*)*>)((?:(?!<\1).)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}