re = /(?:<(a|img)(?:\s[^>]*)*>)((?:(?!<\1).)*)/m
str = '
<img>content</img> <img src="some-pic-url">content</img>
<a> content </a> <a href="url">content</a>
<a href="url">content</img>
<img src="some-pic-url">content</a>
<a href="url">content
<img src="some-pic-url">content'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end