package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^B*((AB*){2})*B*$`)
var str = `AABBABA
BABBAB
BABBBA
BABAAB
AABBABABA
A
AAA
ABABABABA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}