$re = '/^B*((AB*){2})*B*$/m';
$str = 'AABBABA
BABBAB
BABBBA
BABAAB
AABBABABA
A
AAA
ABABABABA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);