import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^B*((AB*){2})*B*$";
final String string = "AABBABA\n"
+ "BABBAB\n"
+ "BABBBA\n"
+ "BABAAB\n"
+ "AABBABABA\n"
+ "A\n"
+ "AAA\n"
+ "ABABABABA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}