using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(<a href=""#"">))([\s\S]| |w\[0-9]| )+?(?=(<\/a>))";
string input = @"<ul><li><a href=""#"">test1</a></li><li><a href=""#"">test2</a></li><a href=""#"">test3</a></li></ul>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}