$re = '/(?<=(<a href="#">))([\s\S]| |w\[0-9]| )+?(?=(<\/a>))/';
$str = '<ul><li><a href="#">test1</a></li><li><a href="#">test2</a></li><a href="#">test3</a></li></ul>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);