const regex = /(?<=(<a href="#">))([\s\S]| |w\[0-9]| )+?(?=(<\/a>))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(<a href="#">))([\\s\\S]| |w\\[0-9]| )+?(?=(<\\\/a>))', 'g')
const str = `<ul><li><a href="#">test1</a></li><li><a href="#">test2</a></li><a href="#">test3</a></li></ul>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}