using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Volume{).+(?=})";
string input = @"\?\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\
\?\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\
\?\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\
\?\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\ ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}