import re
regex = re.compile(r"(?<=Volume{).+(?=})")
test_str = ("\\?\\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\\\n"
"\\?\\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\\\n"
"\\?\\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\\\n"
"\\?\\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\\ ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")