import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Volume\\{).+(?=\\})";
final String string = "\\?\\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\\\n"
+ "\\?\\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\\\n"
+ "\\?\\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\\\n"
+ "\\?\\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\\\n"
+ "\\?\\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\\\n"
+ "\\?\\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\\\n"
+ "\\?\\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\\\n"
+ "\\?\\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\\ ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}