const regex = /(?<=Volume{).+(?=})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Volume{).+(?=})', 'g')
const str = `\\?\\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\\
\\?\\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\\
\\?\\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\\
\\?\\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\\ `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}