use strict;
my $str = '\\?\\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\\
\\?\\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\\
\\?\\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\\
\\?\\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\\
\\?\\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\\ ';
my $regex = qr/(?<=Volume{).+(?=})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}