using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"page\?[^#]*\buid=(\d+)(?:[^#]*#(\d+))?";
string input = @"t3://page?uid=2879&L=1#23260
t3://page?uid=2879#23263
t3://page?uid=2881&L=0
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}