// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"page\?[^#]*\buid=(\d+)(?:[^#]*#(\d+))?").unwrap();
let string = "t3://page?uid=2879&L=1#23260
t3://page?uid=2879#23263
t3://page?uid=2881&L=0
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}