const regex = /page\?[^#]*\buid=(\d+)(?:[^#]*#(\d+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('page\\?[^#]*\\buid=(\\d+)(?:[^#]*#(\\d+))?', 'g')
const str = `t3://page?uid=2879&L=1#23260
t3://page?uid=2879#23263
t3://page?uid=2881&L=0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}