import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "page\\?[^#]*\\buid=(\\d+)(?:[^#]*#(\\d+))?";
final String string = "t3://page?uid=2879&L=1#23260\n"
+ "t3://page?uid=2879#23263\n"
+ "t3://page?uid=2881&L=0\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}