$re = '/page\?[^#]*\buid=(\d+)(?:[^#]*#(\d+))?/';
$str = 't3://page?uid=2879&L=1#23260
t3://page?uid=2879#23263
t3://page?uid=2881&L=0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);