using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^\/a] *[^>]*>[^<]*(textToMatch)";
string input = @"<p>
bla bla bla textToMatch blabla
</p>
<a href=""http://www.google.com"" alt=""textToMatch"">bla textToMatch</a>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}