$re = '/<[^\/a] *[^>]*>[^<]*(textToMatch)/';
$str = '<p>
bla bla bla textToMatch blabla
</p>
<a href="http://www.google.com" alt="textToMatch">bla textToMatch</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);