package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^\/a] *[^>]*>[^<]*(textToMatch)`)
var str = `<p>
bla bla bla textToMatch blabla
</p>
<a href="http://www.google.com" alt="textToMatch">bla textToMatch</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}