re = /<[^\/a] *[^>]*>[^<]*(textToMatch)/
str = '<p>
bla bla bla textToMatch blabla
</p>
<a href="http://www.google.com" alt="textToMatch">bla textToMatch</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end