import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^\\/a] *[^>]*>[^<]*(textToMatch)";
final String string = "<p>\n"
+ "bla bla bla textToMatch blabla\n"
+ "</p>\n"
+ "<a href=\"http://www.google.com\" alt=\"textToMatch\">bla textToMatch</a>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}