import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([(-.+]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+)";
final String string = "Lorem ipsum foo@bar.com dolor sit amet, 555 123555 consectetur adipiscing elit.\n"
+ "Here (works) 0606060606 (not works) 06.06.06.0.06.06 06.06 ... .06.06.06 price is 20. 000.000\n\n"
+ "555.123.4565\n"
+ "+1-(800)-545-2468\n"
+ "+ 1 -(800)-545-2468\n"
+ "2-(800)-545-2468\n"
+ "3-800-545-2468\n"
+ "555-123-3456\n"
+ "555 222 3342\n"
+ "(234) 234 2442\n"
+ "(243)-234-2342\n"
+ "1234567890\n"
+ "123.456.7890\n"
+ "123.4567\n"
+ "123-4567\n"
+ "1234567900\n"
+ "12345678900\n"
+ "+8.4.0.9.6.6.4.3.0.0.9\n\n"
+ "my price is only 20$, 2000$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}