re = /([(-.+]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+)/m
str = 'Lorem ipsum foo@bar.com dolor sit amet, 555 123555 consectetur adipiscing elit.
Here (works) 0606060606 (not works) 06.06.06.0.06.06 06.06 ... .06.06.06 price is 20. 000.000
555.123.4565
+1-(800)-545-2468
+ 1 -(800)-545-2468
2-(800)-545-2468
3-800-545-2468
555-123-3456
555 222 3342
(234) 234 2442
(243)-234-2342
1234567890
123.456.7890
123.4567
123-4567
1234567900
12345678900
+8.4.0.9.6.6.4.3.0.0.9
my price is only 20$, 2000$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end