use strict;
my $str = 'Lorem ipsum foo@bar.com dolor sit amet, 555 123555 consectetur adipiscing elit.
Here (works) 0606060606 (not works) 06.06.06.0.06.06 06.06 ... .06.06.06 price is 20. 000.000
555.123.4565
+1-(800)-545-2468
+ 1 -(800)-545-2468
2-(800)-545-2468
3-800-545-2468
555-123-3456
555 222 3342
(234) 234 2442
(243)-234-2342
1234567890
123.456.7890
123.4567
123-4567
1234567900
12345678900
+8.4.0.9.6.6.4.3.0.0.9
my price is only 20$, 2000$';
my $regex = qr/([(-.+]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+[()-.+ ]*+[0-9]*+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}