using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:\.\d+)?(?:\s*-\s*\d+(?:\.\d+)?)?$";
string input = @"1 - 3
1.35 - 78.55
34
567.78";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}