$re = '/^\d+(?:\.\d+)?(?:\s*-\s*\d+(?:\.\d+)?)?$/m';
$str = '1 - 3
1.35 - 78.55
34
567.78';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);