package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.\d+)?(?:\s*-\s*\d+(?:\.\d+)?)?$`)
var str = `1 - 3
1.35 - 78.55
34
567.78`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}