#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|,)IS(,|$)"
Local $sString = "Consider these lines as invidual rows IN THE DATABASE:" & @CRLF & _
"" & @CRLF & _
"IS" & @CRLF & _
"IS,TS" & @CRLF & _
"WS,CT,IS" & @CRLF & _
"TS-IS" & @CRLF & _
"WS,CT,IS,TS,TS-IS,TS-WS,TS-CT" & @CRLF & _
"WS,CT,NOT JUST IS,TS,TS-IS,TS-WS,TS-CT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")