using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|,)IS(,|$)";
string input = @"Consider these lines as invidual rows IN THE DATABASE:
IS
IS,TS
WS,CT,IS
TS-IS
WS,CT,IS,TS,TS-IS,TS-WS,TS-CT
WS,CT,NOT JUST IS,TS,TS-IS,TS-WS,TS-CT";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}