const regex = /(^|,)IS(,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|,)IS(,|$)', 'gm')
const str = `Consider these lines as invidual rows IN THE DATABASE:
IS
IS,TS
WS,CT,IS
TS-IS
WS,CT,IS,TS,TS-IS,TS-WS,TS-CT
WS,CT,NOT JUST IS,TS,TS-IS,TS-WS,TS-CT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}