import Foundation
let pattern = #"(^|,)IS(,|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Consider these lines as invidual rows IN THE DATABASE:
IS
IS,TS
WS,CT,IS
TS-IS
WS,CT,IS,TS,TS-IS,TS-WS,TS-CT
WS,CT,NOT JUST IS,TS,TS-IS,TS-WS,TS-CT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)