$re = '/[^]+\[Input\][^]+(NewAutoController)[^]+\[.*\]/m';
$str = '[Console]
No = いいえ
Yes = はい
FailedLogin = 現在ログインすることができません。後ほどもう一度お試しください。
OfflineMode = オフラインでプレイしたい場合、Xbox Liveの機能は使用できず、データはセーブされません。
[Input]
ControllerDisconnect = コントローラーが切断されました。コントローラーを再接続して再開しましょう。
NewAutoController = 新しい入力:
[levels]
FreeRoamDesc = お好きにどうぞ
MountainPeak = 山の頂上
Act = 幕
Chapter = チャプター
[cheats]
disallowed_outside_editor = エディター外
^\\[Input\\]
^\\[\\w+\\]
[^]+\\[levels]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;