import re
regex = re.compile(r"[^]+\[Input\][^]+(NewAutoController)[^]+\[.*\]", flags=re.MULTILINE)
test_str = ("[Console]\n"
"No = いいえ\n"
"Yes = はい\n"
"FailedLogin = 現在ログインすることができません。後ほどもう一度お試しください。\n"
"OfflineMode = オフラインでプレイしたい場合、Xbox Liveの機能は使用できず、データはセーブされません。\n\n"
"[Input]\n"
"ControllerDisconnect = コントローラーが切断されました。コントローラーを再接続して再開しましょう。\n"
"NewAutoController = 新しい入力:\n\n"
"[levels]\n"
"FreeRoamDesc = お好きにどうぞ\n"
"MountainPeak = 山の頂上\n"
"Act = 幕\n"
"Chapter = チャプター\n\n"
"[cheats]\n"
"disallowed_outside_editor = エディター外\n\n"
"^\\[Input\\]\n"
"^\\[\\w+\\]\n\n"
"[^]+\\[levels]")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)