import Foundation
let pattern = #"[^]+\[Input\][^]+(NewAutoController)[^]+\[.*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[Console]
No = いいえ
Yes = はい
FailedLogin = 現在ログインすることができません。後ほどもう一度お試しください。
OfflineMode = オフラインでプレイしたい場合、Xbox Liveの機能は使用できず、データはセーブされません。
[Input]
ControllerDisconnect = コントローラーが切断されました。コントローラーを再接続して再開しましょう。
NewAutoController = 新しい入力:
[levels]
FreeRoamDesc = お好きにどうぞ
MountainPeak = 山の頂上
Act = 幕
Chapter = チャプター
[cheats]
disallowed_outside_editor = エディター外
^\[Input\]
^\[\w+\]
[^]+\[levels]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)