const regex = /^
(?=.*?[0-9]) #содержит хотябы одну цифру
(?=.*?[A-Z]) #содержит хотябы одну латинскую прописную букву
(?=.*?[a-z]) #содержит хотябы одну латинскую строчную букву
(?=.*?[^0-9A-Za-z]) #содержит хотябы один знак пунктуации: !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~
#не имеют 6 и более подряд совпадающих символов типа "zzzzzz", "000000"
(?!.*?(.)\1{5,})
#не имеет "плохих" последовательностей типа "123456", "abcdef", "qwerty"
(?!.*?123456)
(?!.*?(?i:qwerty|asdfgh|zxcvbn|qazwsx|abcdef))
#допускаются только цифры, английские буквы и знаки пунктуации
[\x20-\x7e]{8,72} #ограничения по кол-ву символов
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?=.*?[0-9]) #содержит хотябы одну цифру
(?=.*?[A-Z]) #содержит хотябы одну латинскую прописную букву
(?=.*?[a-z]) #содержит хотябы одну латинскую строчную букву
(?=.*?[^0-9A-Za-z]) #содержит хотябы один знак пунктуации: !"#$%&\'()*+,-.\/:;<=>?@[\\]^_`{|}~
#не имеют 6 и более подряд совпадающих символов типа "zzzzzz", "000000"
(?!.*?(.)\\1{5,})
#не имеет "плохих" последовательностей типа "123456", "abcdef", "qwerty"
(?!.*?123456)
(?!.*?(?i:qwerty|asdfgh|zxcvbn|qazwsx|abcdef))
#допускаются только цифры, английские буквы и знаки пунктуации
[\\x20-\\x7e]{8,72} #ограничения по кол-ву символов
$', 'gm')
const str = `_012345_zZ
_123456_zZ
_00000_zZ
_000000_zZ
^@},hJu>[4Bo7TGX
_}24I:9t58Tu?m@e
|YlzEc|1
#m_4xF%t"Bu5jeb\$
12345678aA@
12345678 aA@
12345678aA@
123Qwerty45678aA
^@},^@},^@},
AbCdEfGhIi
abcdefgh123
ABCDEFGH1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}