use strict;
my $str = '_012345_zZ
_123456_zZ
_00000_zZ
_000000_zZ
^@},hJu>[4Bo7TGX
_}24I:9t58Tu?m@e
|YlzEc|1
#m_4xF%t"Bu5jeb$
12345678aA@
12345678 aA@
12345678aA@
123Qwerty45678aA
^@},^@},^@},
AbCdEfGhIi
abcdefgh123
ABCDEFGH1234';
my $regex = qr/^
(?=.*?[0-9]) #содержит хотябы одну цифру
(?=.*?[A-Z]) #содержит хотябы одну латинскую прописную букву
(?=.*?[a-z]) #содержит хотябы одну латинскую строчную букву
(?=.*?[^0-9A-Za-z]) #содержит хотябы один знак пунктуации: !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~
#не имеют 6 и более подряд совпадающих символов типа "zzzzzz", "000000"
(?!.*?(.)\1{5,})
#не имеет "плохих" последовательностей типа "123456", "abcdef", "qwerty"
(?!.*?123456)
(?!.*?(?i:qwerty|asdfgh|zxcvbn|qazwsx|abcdef))
#допускаются только цифры, английские буквы и знаки пунктуации
[\x20-\x7e]{8,72} #ограничения по кол-ву символов
$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}