import re
regex = re.compile(r"""
^
(?=.*?[0-9]) #содержит хотябы одну цифру
(?=.*?[A-Z]) #содержит хотябы одну латинскую прописную букву
(?=.*?[a-z]) #содержит хотябы одну латинскую строчную букву
(?=.*?[^0-9A-Za-z]) #содержит хотябы один знак пунктуации: !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~
#не имеют 6 и более подряд совпадающих символов типа "zzzzzz", "000000"
(?!.*?(.)\1{5,})
#не имеет "плохих" последовательностей типа "123456", "abcdef", "qwerty"
(?!.*?123456)
(?!.*?(?i:qwerty|asdfgh|zxcvbn|qazwsx|abcdef))
#допускаются только цифры, английские буквы и знаки пунктуации
[\x20-\x7e]{8,72} #ограничения по кол-ву символов
$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("_012345_zZ\n"
"_123456_zZ\n"
"_00000_zZ\n"
"_000000_zZ\n"
"^@},hJu>[4Bo7TGX\n"
"_}24I:9t58Tu?m@e\n"
"|YlzEc|1\n"
"#m_4xF%t\"Bu5jeb$\n"
"12345678aA@ \n"
"12345678 aA@\n"
" 12345678aA@\n"
"123Qwerty45678aA\n"
"^@},^@},^@},\n"
"AbCdEfGhIi\n"
"abcdefgh123\n"
"ABCDEFGH1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")