// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?mx)^
(?=.*?[0-9]) #содержит хотябы одну цифру
(?=.*?[A-Z]) #содержит хотябы одну латинскую прописную букву
(?=.*?[a-z]) #содержит хотябы одну латинскую строчную букву
(?=.*?[^0-9A-Za-z]) #содержит хотябы один знак пунктуации: !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~
#не имеют 6 и более подряд совпадающих символов типа "zzzzzz", "000000"
(?!.*?(.)\1{5,})
#не имеет "плохих" последовательностей типа "123456", "abcdef", "qwerty"
(?!.*?123456)
(?!.*?(?i:qwerty|asdfgh|zxcvbn|qazwsx|abcdef))
#допускаются только цифры, английские буквы и знаки пунктуации
[\x20-\x7e]{8,72} #ограничения по кол-ву символов
$"##).unwrap();
let string = "_012345_zZ
_123456_zZ
_00000_zZ
_000000_zZ
^@},hJu>[4Bo7TGX
_}24I:9t58Tu?m@e
|YlzEc|1
#m_4xF%t\"Bu5jeb$
12345678aA@
12345678 aA@
12345678aA@
123Qwerty45678aA
^@},^@},^@},
AbCdEfGhIi
abcdefgh123
ABCDEFGH1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}