#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=>)[^<]*myText[^<]*"
Local $sString = ">myText<" & @CRLF & _
">This is myText<" & @CRLF & _
">This is myText and I need it changed<" & @CRLF & _
">This is my Text and it should not be changed<" & @CRLF & _
">no changes needed<"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")