import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>)[^<]*myText[^<]*";
final String string = ">myText<\n"
+ ">This is myText<\n"
+ ">This is myText and I need it changed<\n"
+ ">This is my Text and it should not be changed<\n"
+ ">no changes needed<";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}