$re = '/(?<=>)[^<]*myText[^<]*/m';
$str = '>myText<
>This is myText<
>This is myText and I need it changed<
>This is my Text and it should not be changed<
>no changes needed<';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);