re = /(?<=>)[^<]*myText[^<]*/m
str = '>myText<
>This is myText<
>This is myText and I need it changed<
>This is my Text and it should not be changed<
>no changes needed<'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end