using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)[^<]*myText[^<]*";
string input = @">myText<
>This is myText<
>This is myText and I need it changed<
>This is my Text and it should not be changed<
>no changes needed<";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}